summaryrefslogtreecommitdiff
path: root/node_modules/ua-parser/cpp/CMakeLists.txt
diff options
context:
space:
mode:
authorMinteck <contact@minteck.org>2022-08-10 10:38:44 +0200
committerMinteck <contact@minteck.org>2022-08-10 10:38:44 +0200
commitc6dbf0450566c40efc4a26f4f0717452b6ef95cd (patch)
treeb4be2d508223820d0a77d5a3e35e82684da3b6ec /node_modules/ua-parser/cpp/CMakeLists.txt
downloadhornchat-c6dbf0450566c40efc4a26f4f0717452b6ef95cd.tar.gz
hornchat-c6dbf0450566c40efc4a26f4f0717452b6ef95cd.tar.bz2
hornchat-c6dbf0450566c40efc4a26f4f0717452b6ef95cd.zip
Initial commitHEADmane
Diffstat (limited to 'node_modules/ua-parser/cpp/CMakeLists.txt')
-rw-r--r--node_modules/ua-parser/cpp/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/node_modules/ua-parser/cpp/CMakeLists.txt b/node_modules/ua-parser/cpp/CMakeLists.txt
new file mode 100644
index 0000000..3a5a25a
--- /dev/null
+++ b/node_modules/ua-parser/cpp/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Copyright 2013 Andrew Punch
+#
+# Licensed under the Apache License, Version 2.0 (the 'License')
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an 'AS IS' BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cmake_minimum_required(VERSION 2.8)
+
+set(CMAKE_CXX_FLAGS "-g")
+
+if(COMMAND cmake_policy)
+ cmake_policy(SET CMP0003 NEW)
+endif(COMMAND cmake_policy)
+
+add_library(ua_parser ua_parser.cpp)
+target_link_libraries(ua_parser yaml-cpp boost_regex)
+
+add_executable(ua_parser_cli main.cpp)
+target_link_libraries(ua_parser_cli ua_parser)
+
+add_executable(ua_parser_test ua_parser_test.cpp)
+target_link_libraries(ua_parser_test ua_parser gtest pthread)